IMAP piece fails to load data

I’m trying to use the IMAP piece (v0.2.1) to check email. The connection to IMAP succeeds with no errors, but when I press the “Load data” button under “Generate Sample Data”, it says “No results found,” “Testing data failed. Please ensure that the settings are correct or try again.”

I’ve sent myself several test emails to that IMAP inbox and I’ve tried testing it with and without filters, like the “from” email address exactly from the email I sent the email from. I keep getting the same “No results found” error.

I am using service, which actually uses Google mail services on the backend. I don’t think this is the problem though because the connection to the IMAP server connects sucessfully.

Does anyone else have any problems with checking IMAP email? Or is there are reason why I’m getting this error?

Hey Benwhut,

I am tracking this issue down, was there any emails avaiable in past 24 hours from the time you did the test?

Hi @abuaboud. Thanks for looking into this for me.

Yes, when I sent test emails over the last few days, I would run the activepieces “Load data” within the next few hours after sending, but it keeps giving me the “No results found” error.

If there is a way I can privately send you some temporary IMAP credentials, perhaps you could try it out and see if it works for you?

@benwhut You can send a message here and mention @abuaboud once you do so he pays attention to it

Hi @abuaboud . I am facing issues in connecting my Imap email also .

it says : Internal Connection error, failed please check your console.

@Vyshakh_OJ Gmail? Can you screenshot the settings of the connection without credentials?

Its not gmail. Its webmail hosted.

Did you try the same settings with another IMAP provider? @Vyshakh_OJ

Yes. It works on my phone. I have set it up.

Strangely, i kept the port as 143 and its working . I am not sure why.

Did you try with the “Use TLS” checked? @Vyshakh_OJ

I thought I did send a message to @abuaboud in my message above yours…

So it worked on Activepieces with the port 143? @Vyshakh_OJ

I mean you can DM here, but maybe you can share a screenshot here as well? @benwhut


Hi, thats right, it works on port 143

I have the same issue as @benwhut

I am able to get the IMAP connection working (with and without TLS), but every time I click “Load Data”, I get the same error message as shared above:
“No results found. Testing data failed. Please ensure that the settings are correct or try again.”

I am connecting to my mailbox on my web host, and it makes no difference whether there are recent emails (last 24h) in the inbox or not to my results.

Nice to hear I’m not the only one. Now just waiting to hear back from @abuaboud

Same issue! Almost never loads any data.

I am currently working on rewriting the connector with another library, as It’s has inconsistent behavior which i can’t find the issue because of that.


I think this is needed :fire:

One thing some users reported is that the emails in the sample weren’t coming in the right order (and not the most recent ones).