IMAP piece fails to load data


I released new version (0.2.2) It should be released in 5 minutes from now, I have removed filters as they were causing slowness and replacing the library please use branch piece as your filtration logic.

Loading test data should work and the trigger should be more reliable.

@karla If you already have flow published, you need to fix the settings and republish the flow again.


Thanks, updated! Let’s see how it goes… :slightly_smiling_face:

1 Like

Please let us know @karla

Thanks for updating this @abuaboud! My version says 0.2.2 now.

I can see the filters have been removed and I can now select the mailbox (I selected INBOX).

I reconnected my IMAP account, which connects successfully.

However, I get the same error message as before when I click the “Load data” button:

“No results found”
Testing data failed. Please ensure that the settings are correct or try again.

I’ve sent myself a few emails within 15 minutes and I can see they were received in my inbox for that email.

Hi @benwhut

Do you mind if you can share temporary credentials so i can figure out the issue?

I will dm you here.


same as @benwhut unfortunately, connected successfully, but emails are not being picked up.
Same issue as well when testing: " No results found

Load data

Testing data failed. Please ensure that the settings are correct or try again."

Sent to you via private message. Thanks!

@benwhut Thank you for the credentials, I finally found it, there were an bug two network requests sent in parallel, the order of completion is not fixed that why it worked sometimes and sometimes not, I only could reproduce it with your imap credentials :smiley: , It’s fixed now in 0.2.3 (should be out in 5 minutes)

@karla try again now.

I’ll try in a few moments, but just to let you know, that until 0.2.1 the emails were picked up twice, not sure if this is what you were just saying, and its fixed now.

Works great now. Thank you so much for fixing this @abuaboud!

Do you want to add the filters back in or just keep it using the Branch piece to filter things?

Same, it works. Thank you team! :star2::star2::star2::star2::star2:

1 Like

Thank you, all working here now too. Much appreciated.

That’s fantastic news! It was a challenging bug.

@benwhut, it’s recommend to use the branch piece for better visibility and speed. It’s better not to add filters back for above reasons. Please let me know if you encounter any issues or have any questions.

Good to know, thanks again.

One question about the branch piece: is it possible to do multi-branch routing, so instead of just 1 true/false option, can you do many? For example, if option 1, do x, if option 2, do y, if option3, do z, etc. I know this can be done with multiple true/false single branches, but it seems cumbersome and can get unnecessarily complex with 4 or 5 or more branches.

1 Like

I agree with what you, Unfortunately Router piece is currently on the roadmap Branch node support multi branch operations · Issue #1664 · activepieces/activepieces · GitHub

1 Like

Good to know it’s at least in the works. Thanks again!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.