Stopping a running flow

Has anyone had any luck stopping a running flow? Some the flows has been running for close to 3 hours. I don’t think they’re running but appears to be just stuck. I would assume that they would just hit a timeout at some point but it hasn’t happened yet.

This is running as a Docker container in Digital Ocean. Any clue on how to make this stop? I tried stopping, removing the existing container, then running a new container instance.

Created a topic on it too

1 Like

Hi @menacestudio

Let me investigate that

1 Like

Oh, @menacestudio,

I believe there’s a known issue when using memory queue mode and the Docker stops while processing a run. It doesn’t reprocess them when it comes back. We’ll see how we can improve this mode.

However, with Docker Compose mode and Redis, this is already handled:

Sorry for that, they are not running for sure if it’s already been 3 hours.

1 Like

@abuaboud got it. I’m trying to export and re-import on some of these flows to ActivePieces cloud, but I’m having issues. I want to make sure that it works before switching to Docker compose.

It works for smaller flows (10 or less steps) but fails on more complex flows (at least 20-30 steps). It just spins but nothing happens. Is there a bug with the import or do you have suggestions on how to it work?

Thank you for the help.

1 Like

Hi @menacestudio

I think there is version mismatch, can you please upgrade to latest version and give it another try

I think you’re right. I did pulled the latest image and the import seems to be working now. Thanks.

I will try running using docker compose and see if that fixes the flow running indefinitely.

@abuaboud I ran the docker compose -p activepieces up. Is there a separate step where the Postgres password needs to be set?

I’m following the steps here FYI, Docker Compose - Activepieces

@abuaboud I got it working by running a reset on all the containers.

sh tools/

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.