New File added to Drive is either an .mp3 or .m4a audio file for OpenAI transcript, but file not recognized

Simple flow, add .m4a file as “New File” to Google Drive (trigger), but OpenAI transcript piece expects something different, I get the error " “Expected file url or base64 with mimeType, but found value: [object Object]”. I have tried every selection from the offered elements of the offered “New File” input to the “Audio File to Transcribe”, they all give the same error.

Test flow

  1. New File

Google Drive


  1. Transcribe Audio



  1. Create Database Item



Transcribe Audio


Use ChatGPT to generate text


Generate Sample Data

Testing Failed



  "audio": [
    "Expected file url or base64 with mimeType, but found value: [object Object]"

Hello !
The new file trigger is like a notification with the file id, you need to add a google drive step with “read file” action then put the id there and retrieve the file :smiley:

thank you for the help, I added the read file step, but the output of that (file_id) is rejected by OpenAI as invalid file type. This is complicated compared to how Zapier moves an .mp3 new file from GDrive, I didn’t have to do any of these additional steps to get the .mp3 audio over for transcription. What is the purpose of converting the file designation away from its file type in GDrive?

Hi Andy,

We’ll see about making the trigger have the file itself as well as the id, for now is it possible to show us the full error ? and did you use the destination file name input ?

Abdul, here is the error msg: Error while excution:
Error: {“response”:{“status”:400,“body”:{“error”:{“message”:“Invalid file format. Supported formats: [‘flac’, ‘m4a’, ‘mp3’, ‘mp4’, ‘mpeg’, ‘mpga’, ‘oga’, ‘ogg’, ‘wav’, ‘webm’]”,“type”:“invalid_request_error”,“param”:null,“code”:null}}},“request”:{“body”:{“_overheadLength”:391,“_valueLength”:972671,“_valuesToMeasure”:,“writable”:false,“readable”:true,“dataSize”:0,“maxDataSize”:2097152,“pauseStreams”:true,“_released”:true,“_streams”:,“_currentStream”:null,“_insideLoop”:false,“_pendingNext”:false,“_boundary”:“--------------------------238784311531769026306457”,“_events”:{},“_eventsCount”:3}}}

I read this as indicating that the .mp3 file isn’t making it past the “Read File” step. I just added the New File" “New File Name” to Destination file name, but then Activepieces “unexpectedly closed connection” and I can’t reload the page, the error is:
This site can’t be reached
Check if there is a typo in

activepieces back online now, here is the error. The ReadFile step seems to work, note that the input to the OpenAI transcribe step includes the correct file name and type, but the output references “.mp3.mpga” file type, not sure where that mpga appendix came from.


1 Like

Hello Andy,
apologies for the delay,
the file you passed ends with .mp3.mpga, and that’s an invalid file type, could you check that it is having a correct file extension on google drive ?

Hi Abdul,

I have the same problem and my files definitively end either in mp3 or m4a.

Could it be something else about the file that is causing the issue?

Quick update: It seems to have been connected with the codec of the file. I started using another voice recording app and now it’s working fine.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.