IMAP + ChatGPT + SMTP Flow (works on test run, but not when published)

Hey, I put together a relatively simple flow, which runs beautifully on the test run, but the automation doesn’t work.

When an email comes in (via Webmail) it should be captured by the automation, after a little filtering of 5 words (with branch) it should be passed to ChatGPT and then sent the reply back to my email via SMTP.

This process works in the test run, but as soon as I publish and run the automation, nothing happens. Am I missing something? Would greatly appreciate any help.

  • Is there any error message?
  • What plan are you on? depending on your plan it could trigger at 15 - 5 - 1 minute interval? Or is it webhooked and go instantly?

As @Bram suggested, the IMAP trigger is a scheduled one. You can know this from the :clock4: icon next to the trigger name:

So, to confirm whether it’s running or not:

  1. Publish the flow.
  2. Send an email to the address you set up on the trigger step in the Connection popup.
  3. Wait for your sync cycle to pass (the fastest plan is 1 minute).
  4. Check the Runs page in your dashboard and see if there is a run for this flow.

Let us know if you find a run or not. If you don’t, we need to troubleshoot this further.

Thanks for your quick help and suggestions.

I’m in the Activepieces Appsumo Tier 3 plan. The schedule time is 1 minute. But I’ve been waiting for several minutes hours and also wrote more email to test it.

I don’t get any error message, the run just doesn’t start. Only when I click on “Test run” everything is executed.

This is bad, @onay. To troubleshoot this, can you please confirm whether you see any runs in the Runs page in your dashboard?

I’d like to confirm if the run isn’t executed at all or if it’s executed but your condition isn’t met. This will get us closer to understanding the issue.

Ok, this is where it gets a bit weird. After your message I tested it again with a different email address. I sent the test email and a minute later I got a reply email from ChatGPT. So it was working. But then the same email came 4 more times. Under Runs I can see that the run has been triggered 5 times. But what’s annoying is that it didn’t work after that. I tried to sent 6 more emails with 4 different email addresses. So to your question: Flows that don’t take place are not listed under Runs.

I’m experiencing the same problem. It might be due to the cache or something similar. Occasionally, it works, but other times I have to toggle the workflow off and on again to get it working.

I noticed that the Schedule piece doesn’t work properly when the interval is set to 1 minute. However, when I changed it to 2 minutes or more, it started working correctly.

Is there a way to change the run interval?

For me it is automatically 1 minute and I don’t see any settings where I can change it. I also tried to change the trigger from IMAP to Schedule, but then I can’t insert an IMAP step after that.

So here are some things I tried:

  • I deleted the filtering by “Branch” - Doesn’t work.
  • I reconncted IMAP and SMPT again - Doesn’t work
  • I swapped sending via SMTP with sending via Gmail - Doesn’t work
  • I tried to add delays - Doesn’t work

In each case the test run works, but the actual run doesn’t work.

In another automation, I also don’t get any notification on Slack. Can there be any problem with the “Send” command?

And again, runs that don’t work are not listed.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.