How to self host Activepieces on your home and access it over the internet

Hello y’all, I’m back (kinda)

If you have a Raspberry PI, other “mini” server, or anything capable of running Linux; you can host Activepieces at home and get all benefits of the Self-hosted version. You can even process webhooks!!! For free!!!

You can get access to the tutorial here: How to self-host Activepieces at home

If you need any help, feel free to comment there, or here. I’ll try to answer your questions ASAP.

Hi Pablo,

Welcome back, happy to see you again!

I’ve been thinking about self hosting, but not technical at all. Can you see if having a Linux server like this one will do the trick from HyperHost? It is pretty cheap I think and it would be great if that is possible.

KR Bram

@Bram What’s your incentive to self host Activepieces? Geeking out or saving money? Or something else?

I think they don’t sell VPSs, you need a VPS in order to install docker and then AP. I recommend you to check this out:

There is a lot of offers of VPSs for cheap.

Hi @ashrafsam, yeah geeking out. For now I have enough tasks to do everything I like. Maybe the future things will be different, but still not planning on moving away from the cloud.

Met technical knowledge of hosting and setting up systems is very limited. But I do believe it would be good to understand. There are many more open-source solution I would like to make use of but all future plans.

Kr Bram

Thanks I will check it out! Looking forward to dive in deeper

Hey @PFernandez98
I tried following your blog post, but I’m stuck:

  1. Webhook is not getting anything when testing and
  2. my local IP is in the Webhook URLs.

Could you help?
Thank you in advance,

Hi @TomB! For number 1, I think this is a AP thing, I think I saw an issue on the community the other day, regarding to this.

For number 2, did you change the env variable here : How to self-host Activepieces at home ?? (How to receive webhooks section)

Hey @PFernandez98
I only realized I needed to change the .env after I had already followed your steps.
Now, I found the .env file and changed from:
Or should it be?:

Once that is done, what should I do now? What are the next steps?

Thank you for replying,

if you are using the tunnel from cloudflare, it should be the https one… after that go to the AP directory (where the .env and the docker-compose.yml files are located) and run this (exactly like that):

docker compose up -d

Just in case, I’m tagging you :slight_smile: @TomB

1 Like

Hey @PFernandez98
Should I first stop my current container of AP?
As when I ran you command, I got:

:~/activepieces $ docker compose up -d
WARN[0000] /home/dr/activepieces/docker-compose.yml: `version` is obsolete 
[+] Running 2/2
 ✔ Container redis         Recreated                                                                                                                                                                                                    2.6s 
 ✔ Container postgres      Recreated                                                                                                                                                                                                    2.6s 
 ⠋ Container activepieces  Creating                                                                                                                                                                                                     0.0s 
Error response from daemon: Conflict. The container name "/activepieces" is already in use by container "LONGSTRINGALPHANUMERICSEQUENCE". You have to remove (or rename) that container to be able to reuse that name.

So I had to remove it first? Or stop? Or both?

Thank you for tagging me.

@TomB I think this error is because of something else… maybe you have two different AP containers?

Nonetheless, I recommend you to do this

docker stop activepieces 
docker rm activepieces

then, try again the docker compose up -d.

If this doesn’t work, execute docker ps and send a screenshot of the result.

1 Like

Thank you @PFernandez98
All is well and working properly
I got my domain to show within webhook’s URL and the test went through.

Nice!! I’m glad it worked

After running the above, my AP version changed from 0.26.1 to 0.26.0
I’m sure of this because I had checked yesterday that my version was up to date and 0.26.1 has been out for two weeks now.
Any thoughts? Guidance?
Thank you again

in your docker-compose.yml, just change the activepieces image version


1 Like

After that, you need to do the docker compose up -d again

Thank you very much for replying.
Please clarify if I don’t need to run

docker stop activepieces 
docker rm activepieces

and not:

docker compose up -d --remove-orphans


docker compose up -d

:face_with_open_eyes_and_hand_over_mouth: Sorry I ask, we are not going at the same speed…
I’m a :microbe:, while you are a :racing_car: