Flow just disappeared - and it says "Contact support"

So I was editing a rather big flow, and then everything got wiped out when I clicked on “Publish”. It than gave me a red warning in the bottom, and everything disappeared.

It only shows “Select trigger” in the Flow. (Like it does when you start a new flow.)

Why did this happen?

Is it a way to get it all back?

Hi Preben

I am sorry to hear that, can you please DM me here the flow id.

Hi @abuaboud ,
thank you. I just sent a PM :slight_smile:

Hi @Preben,

I have forwarded this to the team. It seems that the flow was interrupted or threw an error during publishing from our side. In the meantime, I believe you will find the flow if you switch the view from “Draft” to “Published.”


I can help you export the flow through the API so you can import it again, please let me know if you want me to do that.

Thank you,

It happened when I clicked “Publish”. It then threw a red “you have to refresh”, and then it was all gone.

Going between Draft and Publish doesn’t do anything.

Yes, I would love to get this back. Not sure how the API work.

Thank you Mo :slightly_smiling_face:

I have to correct this. I tried again now, and now it comes back when I enter “Published”. But I can’t edit it.

The Export button will unfortunately download the latest draft version rather than the selected version. So @abuaboud still needs to help you with this.

@abuaboud , now this has happened again. See the thread in “Bugs”

I almost don’t dare touching ActivePieces now, since it just delete my work.

Sorry about this @Preben If the work is gone, you’re totally right to get scared. The team will see what’s going on and what the impact is. We’ll keep you updated on the other thread

@abuaboud recovered the Flow. There is a bug somewhere that deletes it, but together I think we will find it and make AP better. This is the best automation tools of all I have. Just need it to be stabile, and I think that will come. :slightly_smiling_face: Just a lot of frustration yesterday.

I have same issue as this and this guy. I’m using self hosted docker container :latest version. Any chance of recovering on self hosted site?

Hi @dbbuda It’s possible yes if it’s in published mode.

Do you know a way to reproduce the issue that would help us a lot

I’ll try to remember steps, but they probably won’t be exact step by step.

Flow stopped working because of second piece “contiguity” had issues, so the rest of the flow didn’t work. contiguity issues are related to 504 an 500 errors because of, quoting: “SMS service interruptions due to a carrier outage”.

So, I hit test flow (at the top) and see that flow is not passing. Went back to dashboard and back to flow, and I noticed flow is gone and there were a lot of errors in console.

Basically, it’s very difficult to reproduce, since I don’t know exactly what caused this bug not I pay attention to details of what am I doing. I assume it’s something with websocket connection.

1 Like

@dbbuda @abuaboud Did you guys resolve this? I’ve just run in to the same issue with self-hosted.

I hadn’t even tried to save a change. I was just clicking through the pieces and I got the same error. Flow completely disappeared.

I managed to recover a copy of the published flow template by looking through the network tab in Chrome dev tools at the JSON response to the flow API call.
e.g. Get the JSON response from api/v1/flows/<flow id>?versionId=<some version id>.
Update the JSON layout to match the structure you get when exporting a flow and then import it into a new flow.

@abuaboud This is a pretty bad bug that looks to be effecting others too. Is there any easier way to recover from this when self-hosting?

Hi @GFoley83 I am still trying to find a way to reproduce and fix it.

Moved this to bugs.

1 Like

Hello guys, just to be clear, this issue you guys are facing is after publishing ? and not during editing a flow by changing some input values or deleting/moving/duplicating a step ?

In my case this is what happened.

I don’t know about what happened for @GFoley83 and @dbbuda

Are you self hosting as well ?

No, I am using https://cloud.activepieces.com/

Indeed. Same thing happened to me, 3 times already