API Invalid Array Length Error

Hi Team,
Our API call is throwing a “Invalid Array Length Error”.
The HTTP request has successful test and we can see all the json/data.
However the insert data into g-sheet is not working and throws this error, why?
We tested the very same same API on Bardeen and pushed data into gsheet issue free.
What are we doing wrong here?

@mr-oodler can you show me how you are mapping data(fetched from HTTP request) into Google Sheets ?

Hi @kishanprmr ,
I am not mapping any of the data.
Is that the problem?
When I look at the gdoc and the headers, the mapping looks like its been done?

@mr-oodler You need to map data that you want to insert in Google Sheets row From HTTP response.
Right now you are sending empty data to Google Sheets that causing this error.

Hi @kishanprmr,
Can you show me/direct me to example of how to do this?
If your referring to clicking in each map-able input to make the map selection, I have tried this several times but the screen freezes every time I click Insert or the Arrow icon?

Sure. You can refer this guide for passing data between steps .

Try refreshing page and make sure HTTP step is tested. Then you can click on > button to see HTTP response body and map appropriate value to GSheets Column.

Hi @kishanprmr , that does not work.
Saving HTTP after testing throws a save error.
Which at a guess is why the add response body does not work on gsheet.
See video, pls help.

Hi @mr-oodler ,
Thanks for video input. Seems like internet or browser extensions are not causing this error.
I think @abuaboud can help us to solve this issue.

I think the response is too long for us to store, can you do the http request separately on Postman and seeing the size of the response then posting that here ?
In regards to your google sheets error, it is because you have an empty list of rows, we will need to improve the error message on that.

Hi @Abdul,
Needed to research what Postman was.
After creating account and running GET, time 4.81s, size 5.1 mg.
Same call on Bardeen posts perfectly to our gsheet at 3046 rows.
I don’t want to be forced to use Bardeen when I have you guys.
As for g-sheet, the Action is Insert Row. We want the GET request to get the data and push it to our g-sheet irrespective if it has data in it or not, just add or overwrite. Can we do that? if not what is the play here, how can I get all the data and have it overrite whats there? The point of this is to sync data from our app to the gsheet.

Hi guys,
Its been 4 days, can you please help?

Hi @mr-oodler You’re right, this is a bug. I’ll move this topic to Bugs

However, because other HTTP requests are working well at our end, are you able to share settings of the HTTP step with us here? Or maybe privately if things can’t be public.

We need to see what kind/size of data you’re receiving from the endpoint in order to debug and fix this.

Hi @mr-oodler Can you provide more info on this?

Hi @ashrafsam ,

I did provide the settings in the email response to keep it private.

Il will respond via your email again now.


Hi @mr-oodler Which email? Can you DM me here?

Hi @ashrafsam ,

I sent you private DM a week ago.

Can you or someone pls help me with this?


Hi @mr-oodler,

It seems that the issue is due to the sample data being too large. I can’t see the URL, but do you know how large the payload is?

This shouldn’t occur during runtime. Can you check the size of the returned payload? Also, please try using “Test Flow” instead of “Test Step.” Does it work?

Hi Mohammad,

Return payload is aprox 3K rows by 50/60 columns.

Payload should not be too large as the sync works 100% using Bardeen.

I need it to do the same with AP.

I will PM you what I sent Ash - done - pls confirm ur on dame dm?


By testing using the information sent on DM, I can confirm that the issue happens due to the large data being returned from the HTTP request.

The data might not be large for the backend to handle, but it caused the UI to become unresponsive and showed me the following issues:

When I test in the Sample Data panel:

If I ignore the message and try to select data from this step, I make the browser unresponsive:

@abuaboud I assume this is a frontend bug that needs fixing. Can you confirm?

Hi @ashrafsam @abuaboud ,

Has this been fixed?

3K rows x 30 columns is not massive, its barely a retail stores stock list.

As mentioned, this worked 1st time on Bardeen 2 months ago.

Why is this taking so long to fix?

Pls help.