API Invalid Array Length Error

Hi @mr-oodler

The problem is that when you press the test step on http piece, the HTTP response is approximately 5.5 MB, and it saves the sample data inside the flow. However, it fails because flow data can’t be large, as it could lead to browser issues.

Even if we increase the flow size limit, It will hang the browser when selecting the value from dropdown.

That means we need to rework our flow structure and dropdown design to avoid displaying large values. It’s useful for small data to show the values, but we’re not sure if that’s the right suggestion. Another option is to only display keys or truncate the data, showing only a portion of it in the browser to prevent crashes.

Suggested Workaround:

If you try using “Test Flow” instead of “Test Step,” it should work in the meantime without any issues. If you want to refer to the HTTP response, hover over the step and find its name (e.g., step_2 ), then instead of selecting the HTTP body from the dropdown, you can type {{step_2.body}}. If you want to select a specific field inside the body, you can also type the JSON path as {{step_2.body.field_name}}.

This workaround should resolve your problem.

Please let me know if you have any questions.

Thank you,

Hi @abuaboud @ashrafsam ,

Thanks for that!

If your referring to “Test Flow” option at top of the flow, Vs “Test Step” bottom right - see img 1 below, then I am trying this but the system just hangs and the flow does not display - see img 2 below.

I have tested this on multiple browsers with same result.

As this flow & webhook to pull data has taken several months so far, could your support please go into my account and try to get this to work for us? I have given you access in admin.

As mentioned, this webhook worked 1st time on Bardeen but i paid for max level ActivePieces so I dont want to be forced to use another product for what should be a simple webhook data dump.

Kind Regards

Hi @ashrafsam @abuaboud ,

Can someone please help?


Hi @ashrafsam @Abdul,

Common guys… 72 days to resolve a webhook to google sheets issue is not good.

Where is Active Pieces direct support???


Hi @mr-oodler

Please Book me there Mohammad Abu Aboud | Cal.com

the bug was in the frontend, which was checking the flow run status every 1.5 seconds. If it succeeded, it was processed with loading the log. The problem when the loading log took more than 1.5 seconds. In such cases, the next iteration would kick in and cancel the loading log, causing the log to load indefinitely.

The issue has now been fixed and released to the cloud. Test Flow is now working as intended.

Hi @abuaboud ,

This flow is not fixed at all.

Step 2 > Send HTTP request > the test works BUT it is not saving and then throws this error "“You have unsaved changes on this page due to network disconnection.”

Step 3 > Insert Row > throws this error with no prompt “Invalid array length”.

Step 3 > Insert Row > throws this error when clicking Test Flow “Run failed (DNwi7vtlEIp8RBCWuTM2n)”.

I have re-scheduled meeting today, maybe you show me this working and what I am doing wrong. :slight_smile:
See u soon, thanks James