ActivePieces Webhook Duplication firing multiple times at once

Is there a fix for this? It seems like a common problem. I have other webhooks and they are all doing the same thing.

Hi @Jalpowel,

I am not aware of any issues like that

Are you self-hosting? What is the activepieces version? (Please check /api/v1/flags)

Take Look here → ActivePieces Webhook Duplication and Mapping Issue in VPS Environments

I am not self hosting. I have/using a tier 3 appsumo subscription.


Now it’s automatically attempting 4 times. I toggled the switch “Auto Retry on Failure
Automatically retry up to four attempts when failed”.
When toggled on it will successfully return four responses when it should only return the 1st successful response and not attempt the other three. And when I toggle it off it returns four blank responses.

These tasks are being deducted 4x.

I solved this for me by exporting the flow, deleting it, then importing the flow again.

Hi @Christian_DeRamos

Was the trigger webhook as well?

Hi @Jalpowel
How do you send the payload? can you explain more?

@abuaboud No my trigger was the scheduler every 2 mins.

But it has happened on webhooks too and new gsheet rows. I narrowed it down to when I turn off a flow, edit it and then publish it again it seems to happen, but not every time.

I solved the issue. I had created multiple IDs (on the 3rd party app) for the same webhook. After I deleted all IDs except one, the webhook worked.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.