Webhook not collecting

I have active pieces through Task Magic and wanted to try and figure out why my webhook won’t pick up any triggers.

I’ve tried jotform , Google sheets and a few other options to feed data to the webhook but it doesn’t catch anything.

Has anyone been successful with using webhooks?

I was gonna submit the same question.
So can someone please provide an example of the webhook and http step?
I have a webhook that needs to receive information. Thanks!

Hi @digitalplug,

I have debugged this problem with a user over Discord, and the issue was with the TaskMagic version, as it worked on our cloud version with that user. Could you please give it a try on https://cloud.activepieces.com/ and let me know if the issue still there?

We don’t have an official partnership with TaskMagic. They have Activepieces as there is open source community edition. They have modified the community edition (different from the cloud), and we are not aware of the modifications they have made. Therefore, it’s best to ask them about this issue.

Happy debug further if the issue is with the cloud or our community edition.

Hi @karla,

I believe this is a different question from what the original post intended. If you want to send data from ActivePieces, you should use the HTTP piece. On the other hand, if you want to receive data, you should use the Webhook Trigger. It provides you with a unique link that can be called from any other services (if they support webhooks), allowing them to send data to that URL.

Please let me know if you have any specific questions I can assist you with.

It says " If you are expecting a reply from this webhook, append /sync to the URL." - so yes, I need to receive info from the webhook, but could you please tell me how to modify the link and add sync?

Hi @karla,

If you want to use the endpoint to return data, use the action “Return Response” from the HTTP piece and append “/sync” to the generated URL like this:


1 Like

thanks, everything worked!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.