Webhook Catch not catching test

I’m on self-hosted, trying to send data from HighLevel Workflow to ActivePieces.

In AP, I selected Trigger the Webhook then Catch Webhook. Copied URL. [I did not include the /sync]
In HL Automation Workflows, I’ve created a trigger Customer Replied and Action Webhook (post, pasted the ap’s url). Saved Action then Saved workflow.
In HL, I creating a new contact with email and US telephone number.
I tested the workflow from HL by selecting the newly created contact but it keeps failing. Is it not leaving HL or AP not receiving it as AP keeps saying
“Generate Sample Data
Testing trigger
Action Required: Call your webhook url.”
I’ve contacted HL Customer Support and they said the URL is the problem. The website cannot be reached.

I’m a newbie… I know this must be stupid simple.
Please help

After tinkering, I realized since my AP install is exposed through Cloudflare Zero Trust… I had to change the IP digits to my domain to reach webhook URL.
I ran the HL Workflow Test and this is what I got:
“Event Details
All event related details can be found here
Active Parts
Event Status
webhook response: {}”

I got HL tech support to confirm the Test was properly initiated and from executed, but my AP is still stuck with:
“Generate Sample Data
Testing trigger
Action Required: Call your webhook url.”

Please help?

Hi @TomB

Can you please confirm the webhook piece version is 0.1.3, If so can you try with testing url the one that ends with /test

Please let me know if that works.

Hi @abuaboud
Webhook is v0.1.3

I tried the /test url and it is still stuck on Testing Trigger with message
“Action Required:
Call your webhook url.”

How can I change my AP_FRONTEND_URL and what are the steps once I change it?

Did you try to open the URL directly in the browser? What does it return? It should at least save empty body in the test data, If not we might be able to see helpful error

Hi @abuaboud

The URLs I’m given by my AP install for the Webhook are:
Production URL:


Testing URL:


Now when I go to the above URLs, I get:

This site doesn't support HTTPS.

Since I’m self-hosting my AP on my local computer using Cloudflare Zero Trust Tunnel with a custom domain. The AP port associated with CF is assigned a sub.domain*.
When I change the IP in the Webhook URL with my sub.domain, I get


*sub.domain webhook URL format:
http://sub.domain.com/api/v1/webhooks/SoMeCoDeTHiNG redirects to below

Hey @TomB , probably you’d like to update this

Hey @PFernandez98
Thank you for resolving my above issues :+1:

I have got the same issue and don’t know how to solve this being a non tech guy. It use to work properly without any issue earlier. I guess AP have made some changes but not added the guide for the non tech people. Looks like automation was there to help but it’s creating more issues in the workflow now.

Hi @ashgreyshift

Can you provide more information? Are you self hosting? What is the piece webhook version?

I’m not sure if it’s Self Hosting or Cloud. I took a plan from AppSumo. To be honest I’m a non-tech guy so sorry for bothering you guys in advance.

Earlier I use to copy the URL and paste it into other applications like Waalaxy, Sendspark etc while coming back to Activepieces ‘Press’ on ‘Test’ and the data will automatically populate which isn’t hapenning now.

Is there any change in the step? If you could just help me with steps I will try doing it…

Hi @ashgreyshift

You are on the cloud, I will double check on Monday, but for now please paste the testing url and try to perform the action on the third party, does it populate a sample data?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.