Webhook Body List is Empty

I setup a flow and the webhook body, I tested the flow and send data to the webhook URL, it was succesful but the body is empty.

Please how do I fix this?

Hi @sheriffsos Please post enough specific information about your case in order for us to be able to help.

So I setup the flow as seen below, I generated sample data and it was successful sent to the webhook

In the second step as seen below, I wanted to use the body path but it is showing empty list

Is my explanation clear now?

Yes @sheriffsos Thank you. Can you show me how you send the request and how you include the body?

I sent the request from the my app which I already added the webhook url to the backend and as you can see the data was sent successfully to the webhook url.

And for the body, I just clicked on the body on the data to insert automatically but it missed the parameter I needed, Then I tried custom path as seen below, still not working

I’m currently using pipedream and I want to migrate all my flow to activepieces.

I noticed that you’re sending the data as query params not in the body, the body is the JSON editor below these query params. Do you see it? @sheriffsos

Yes that’s how I set it up on pipedreams. I have tried the body as well initially but not working. Infact when I tested it, it failed. Then I reverted back to query param.

Oh sorry, you weren’t showing me how you sent the data to the webhook.

Can you show us in the code how you send the data? @sheriffsos

The URL is included in the admin backend of my app, and I trigger it on the registration page.

Like I said, it is working well with my current provider. Don’t know why I cant get it to work here

I think I am able to reproduce the issue, I am taking look will provide an update tomorrow earky.

I think this issue is because we don’t support form data in webhooks? Not sure but I’m moving this to Bugs since @abuaboud confirmed it.

Thanks team. I love activepieces with the sleek UI and would be glad if this can be sorted. I got the appsumo LTD

@ashrafsam @abuaboud It looks like I have the same problem.
I POST data to webhook url ( application/x-www-form-urlencoded ) and this is my json file working when I clic on test :
“ID”: “1”,
“Body”: “DevisCommande”,
“number”: “+33756139279”,
“userID”: “0”,
“message”: “Nouvelle%20vente%20pour%20un%20montant%20total%20de%20{{trigger[‘body’][‘order_details’][‘total_TTC’]}}%E2%82%AC%20TTC%20en%20provenance%20de%20{{trigger[‘body’][‘billing_information’][‘company’]}}%2C%20%20Nom%20du%20contact%20%3A%20{{trigger[‘body’][‘billing_information’][‘contact’]}}%20et%20N%C2%B0%20de%20t%C3%A9l%C3%A9phone%20%3A%20{{trigger[‘body’][‘billing_information’][‘phone’]}}”,
“simSlot”: “0”,
“type”: “sms”,
“deviceID”: “1015|0”

All is working well during the test. As you can see, some of the data are fixed like “deviceID”: “1015|0” and others as well, so I created an advanced mapping and my json became :
“ID”: “{{step_3[‘ID’]}}”,
“Body”: “{{step_3[‘Body’]}}”,
“number”: “{{step_3[‘number’]}}”,
“userID”: “{{step_3[‘userID’]}}”,
“message”: “Nouvelle%20vente%20pour%20un%20montant%20total%20de%20{{trigger[‘body’][‘order_details’][‘total_TTC’]}}%E2%82%AC%20TTC%20en%20provenance%20de%20{{trigger[‘body’][‘billing_information’][‘company’]}}%2C%20%20Nom%20du%20contact%20%3A%20{{trigger[‘body’][‘billing_information’][‘contact’]}}%20et%20N%C2%B0%20de%20t%C3%A9l%C3%A9phone%20%3A%20{{trigger[‘body’][‘billing_information’][‘phone’]}}”,
“simSlot”: “{{step_3[‘simSlot’]}}”,
“type”: “{{step_3[‘type’]}}”,
“deviceID”: “{{step_3[‘deviceID’]}}”

When I test, it works, but when I publish, body is also empty.
This is the link to flow where I have the issue : Activepieces

How can this be fixed?

Update on the problem or Bug:
This run works:
This one returns an empty body:

This is the same flow and I can’t explain why, one works and the other doesn’t


Closing this issue, as It should be already fixed.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.