Upload to S3 - Permissions problem [SOLVED]

My final step in my Workflow is to upload a Jpeg to S3 but I get this error from Amazon:
“The bucket does not allow ACLs”
I have tried making the folder public, adding a policy, and the files in it are now accessible, but I can’t get it to allow an upload.
How do I enable uploading from AP to an S3 bucket in Amazon?

Edit: I should note that I will need the files to be readable as well.
This is my current policy on that bucket (changed a few numbers as I don’t know what is safe to share)
I don’t really understand policies but this is what I always did to enable loading jpegs publicly from a bucket.

{
    "Version": "2012-10-17",
    "Id": "Policy12345678901",
    "Statement": [
        {
            "Sid": "Stmt12345678987",
            "Effect": "Allow",
            "Principal": "*",
            "Action": "s3:GetObject",
            "Resource": "arn:aws:s3:::myfoldernamehere/*"
        }
    ]
}

Figured it out!

I enabled ACL in the bucket here:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.