Twitter Demo - Fail To Test - Twitter piece Output Undefined

Testing Active Pieces with Twitter Demo, however. Twitter keeps giving me an error.

I run the test and it says output| undefined

Some one please help.

undefined

Please check the ‘Access Token and Secret’ in Twitter developer account - create it with “Read and Write” permissions.

1 Like

Hi there @Errol_Mathew and welcome to our community :star2:

We updated the error codes for Twitter, it seems you are using an older version, could you please remove the step and add it and also do what our buddy @indresh here asked you ?
Thanks @indresh, happy automation.

Awhh, ok let me take a look there, and see if that works.

What are the callback URLs?
TWITTER ( X ) is asking for this information.

App info
Callback URI / Redirect URL (required)
https:// or scheme://

  • Add another URI / URL
    Website URL (required)
    https://
    Organization name (optional)
    This name will be shown when users authorize your App
    Organization URL (optional)
    This link will be shown when users authorize your App
    https://
    Terms of service (optional)
    A link to your terms of service will be shown when users authorize your App.
    https://
    Privacy policy (optional)
    A link to your privacy policy will be shown when users authorize your App.
    https://

I found this article…
https://help.simplified.com/en/articles/7439020-how-to-add-your-own-twitter-api-key

getting another error here.

{“code”:403}

is there another way to add Read & Write permission without adding Oath urls, and website, maybe that is messing me up?

still working on it.

I dont know why I just realized this, but this note…
SUPER IMPORTANT ON CONNECTING TWITTER

People read the Pop up… ( I’m like a blind person some times! )
:sweat_smile: sweat_smile:

If you don’t have the crednetials down below, please follow these steps to obtain the required credentials:

  1. Go to https://developer.twitter.com/en/portal/projects-and-apps and click on your app settings.
  2. Under the Settings tab then under User authentication settings section, click “Set up”.
  3. Check on Read and write for “App permissions” and Native App for “Type of App”, fill in your website url and let the Callback URI / Redirect URL be (your_website_url)/redirect .
  4. Go back to your app settings page and click the Keys and tokens tab.
  5. Next to API key and secret, click “Regenerate” and copy the following values to the inputs below:
 **Api Key**

 **Api Key Secret**
  1. Next to Access token and secret, click “Regenerate” and copy the following values to the inputs below:
 **Access Token**

 **Access Token Secret**

Alright it’s dumb question time kids: I need a website to create the Oauth URL…
See it says down there.
That’s ok I get it…

So do I make a URL | mywebsite.com is available for purchase - Sedo.com <<-- Oauth being the URL that I have creating in that I am inserting Oauth to the URL as part of the name of that page.

OR

Do I just add Oauth to the website URL from twitter API puttin, ( as in there is no actual URL on my site with /Oath.

This is what happens when there is no docs going all the way through the process to bypass.
Ok let me know.

Where did you read that with the Oauth?
In the twitter Dev acc I just put in google.com or activepieces.com as Website (saw that from a view mentions here and on Youtube when looking at general twitter dev account settings).
What helped for me not getting the 403 was setting the twitter app to “native” (the top one) and then generating a new set of access keys all together.

I’m still dealing with issues just trying to set up this demo,
let me try that and see if it works.

NOT WORKING

ALSO NOT WORKING

With the above settings, I regenerated the keys. Now I am getting this.
image

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.