Take 2: Accessing self hosted activepieces deployment on aws using load balancer url

Previous thread below was closed after not receiving a support response, which was fine because I had moved on to trying Automatisch on elestio, but now I want to try activepieces again, so would like to resurface my issue and get some help based on the logs I shared.

Yeah look like the encryption key issue, use sh scripts/deploy.sh in repository to generate .env and use the value of encryption key

My repo doesn’t contain the scripts directory (though it looks like deploy.sh is in the tools directory, which I also don’t have in my repo) after creating the stack and resources. I’m using the deploy with pulumi option on the activepieces installation docs page. But yea, the git repo created through that process doesn’t have tools or scripts directory.

@abuaboud just following up on this.

@abuaboud in the absence of having deploy.sh to use, I tried updating the stack after adding environment variables in the stack’s deployment settings. As suggested in the initial “create a new project” menu launched after clicking the “Deploy with Pulumi” button, I used openssl rand -hex 15 for AP encryption and openssl rand -hex 32 for JWT. I tried both apEncryptionKey & apJwtSecrect and AP_ENCRYPTION_KEY & AP_JWT_SECRET for the names of the keys (the latter is pictured in the first screenshot). I marked both as secrets (second screenshot) In both cases, neither value seems to be passed when looking at the update outputs (third screenshot).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.