Please help with SMTP connection - it doesn't work

I’m unable to connect my SMTP account. I keep getting the error message:
Connection failed: {“code”:“ETIMEDOUT”,“command”:“CONN”}

I’ve tried different variations of the ‘host’, and I’ve tried both SSL/TLS versions but nothing works.

Please help?

Maybe your smtp host is blocking the connection? Can you try your connection to the SMTP server using other services or apps?
Also, are you using the self-hosted version or the cloud version?

@kemoso also verify that the port is correct.

@kemoso, it’s hard to say for certain with out a little more detail, but I had this error when connecting my outlook account some time ago. It seems that using the TLS port number, if I ticked TLS alongside it, it would timeout every time the same with the non TLS port. Out of curiousty, I tried the TLS port number without ticking the TLS box and it connected instantly, I tried a few test mails and they all sent and were received without issue.

Hopefully this helps.

Kind regards,

Thanks for your feedback.

  1. The email is being hosted in a different email client (gmail)
  2. I’m using the cloud version

Many thanks


Thanks for your feedback.
I’ve tried both SSL/TLS: 465 as well as the Non-SSL: 26

Both don’t seem to work.

Many thanks…

Thanks for your reply.

I tried without ticking ‘TLS’ but unfortunately it still doesn’t work as per: Image 2024-01-13 at 8.43.15 PM

Many thanks…

@kemoso If you want to use Gmail ( or your own domain but using Google Workspace )for sending the emails , I think you can use the “Gmail” Piece, is so much easy and fast.

@kemoso, have you tried port 587 at all? I couldn’t get 465 to work at all.

Getting the same error, and did 587 as what you stated. Works fine now. Thanks.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.