PDF Extract Text cannot continue on Failure

I have a flow that starts by receiving an email and iterates in a loop over the attachments.

For each attachment, I try to extract the text. Some attachments are not PDFs though, so I would like to check if the extraction was succesfull by checking if the extracted text exists

The issue is, I can’t toggle on Continue on Failure for the “Extract Text” step. The button is clickable and it changes to flow to draft state, but nothing changes. It wont get activated. I can activate it for all other blocks just fine, but not for this one where I actually need it.

Is this a known issue? How do I activate Continue on Failure for PDF Extract Text? Or how can I check if it has sucessfully extracted text?

Hi @lsc64,

I think your solution lays on step deeper in the loop item, there you can find your details/PDF

Let me know if this worked for you.

KR Bram

thanks, I have that setup correctly, I think. If all attachments are PDFs it works fine, but sometimes an item is not a PDF. This is okay and expected, I just want to skip that iteration then. But for that to happen, the whole run must not fail when extract text fails, which is why I need to toggle on “Continue on Failure”. But the button doesn’t work.

Could you make a screenshot of what you actually are selecting from the loop item?

Also if not all items are .pdf try usi nog the Branch piece to filter out the non PDFs from the actual PDFs.

Kr Bram

The problem is that the items are all URLs, like {
“item”: “https://cloud.activepieces.com/api/v1/step-files/signed?token=xyz”,
“index”: 1
there is no way to tell the file type without loading the URL

Mmm, not sure what then solution will be then. What if you store those documents in a Google Drive and Run them from there? You must have some sort of File type you then could use for making the distincion between files.

Well, this problem would be solved if the button “Continue on Failure” would just work :smile:

So I hope someone from activepieces can fix this functionality, because it seems it should work.

Opened an issue on gh

1 Like