Not allowing me to post on wordpress

I duplicated the flow and reconnected wordpress, and gave it a different name.
I am sure that I am the admin of the site, and have right to post.
What is happening?

@ashrafsam can you please have a look? Thanks!

@ashrafsam follow up
I also get this:
image

Hi @Elma_Pena,

What is the current role of the user you are trying to create this post with?

It might not be set to the correct permissions as that is also what the error states. It needs to be set to author or higher.

It sometimes also works to deactivate the authentication plug-in. wordpress is a real pain in the #ss when it comes to authenticating.

KR Bram

It works now. the rest API plugin got an update a few hours ago!

1 Like

Hello Elma,
Could you also assist us by providing more details on the specific plugin that helped you achieve success?

I don’t know about the plugin, but I had a similar problem once. I solved it using application specific passwords in Wordpress: Application-Specific Passwords – WordPress.com Support

Maybe that works for you too.