Google Sheets New row trigger not starting

Hi there,

I have Active peace plan that should run flow every minute.

My trigger is a New row in Google Sheets but it does not start flow something at all. What can cause this and how can we fix this?


Is there any runs related to your flow?

can you describe more what is exact issue? did you add new rows after the publish and the flow didn’t start?

There is no run.
I added a new row and it did not trigger the flow.

I now duplicated flow and that one started, but the problem if this is now stable. I need to be sure that every new contact will trigger the flow.

Hi @Petar_Kordic,

It should be stable; I haven’t seen problems like that. The only issue that might appear is that it might not be exactly show every 5 minutes. Usually, there might be a small delay (a couple of minutes) if all the servers are busy, but it should trigger for sure.

Are you facing another issue? Just to confirm, are these the steps you followed?

  1. Duplicate the flow.
  2. Publish it.
  3. Add new rows.
  4. Wait around 5-10 minutes.
  5. There are no runs at all for this flow.

After I duplicated flow it runs in 2-3 minutes. And now all is fine.

I do not know why did not worked before, but duplicated one is working fine.

1 Like

5-10minutes even for 1 minute GS automations? That’s quite a delay, no?

I haven’t experienced this (yet) just wondering if this is a common occurrence during peak usage as some follow-ups need to be fairly fast (5min+ would be too long)? And if it is a bottleneck, any plans to expand server capacity?

Hi @S_M,

It depends on your plan as well, and servers are constantly being increased. However, sometimes there is a peak in traffic. Even with expanding servers, it takes more time before they catch up, so usually, they are queued. It’s not the normal case, but it happens from time to time.

My question was mainly to find out if that’s the issue or if it’s something else.

1 Like

Great, thanks for clarifying!

Hi guys,

I have to inform you that I have still the same problem. I had a few flows that ran as they should, and those were on 20.01.2024. Arter that I had 4 new triggers (my form placed 4 new rows in Google Sheet) and none of them triggered flow. The last flow in the Run section was on 20.01.2024. and after that nothing.

This is very unstable and I do not know how to fix this so that I can rely on this tool.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.