Google Contacts Integration bug?

Hi,
I’m trying to monitor google contacts update. I’m unable to test the step.
Google Contacts Unable to Generate Sample Data.


Thank you in advance for your help.

Hi @Adil

Is there something special in the current contacts? I am trying to find a way to reproduce It currently works in my google contacts

For example can you try another account and see if works? then we try to find the difference

Hi @abuaboud ,
I have tried another account. I could load the contacts from this second account.
I can’t see the differnces between the two accounts. Any idea on how we can check this ?
Thank you for your support.

Hi again,
While trying to get around and get some clues; I went throw the full flow test and it worked.
I could retrieve the updates from the faulty google contacts account event though the Genrate sample data have failed.
I’ll continue working on my automation and see !

Thanks any way

Hi @Adil

If you can find which contact causing the issue, then we can simulate same thing in our side and fix it :smiley:

Thank you,
Mo.

Hi @abuaboud ,
It wasn’t a contact but rather a contact account wich was failing the sample data procedure.
If you want me to perfom a test, let me know which one; I’ll try it.
Thanks

EDIT: The data I was playing with comes from the google account used for test, the one which is working fine. The account I want originally trying to use is still faulty.
Setps :
trigger from gmail acoount 1 : load sample ==> Failure
replace account 1 by account 2
trigger from gmail acoount 2 : load sample ==> Sucess
Put back account 1 : test flow success but load sample data still failing

Here where i was misleaded. The test flow procedure worked because it was using already sampled data from account 2.

Is there any log area where I can see the differences between the two google account processing ?

Hi @abuaboud ,
I’m still stuck.
Any idea how I can debug the faulty account ?

Hi @Adil,

I apologize for missing the previous comments. It’s quite odd; I don’t think there are any other away aside from setting up the local environment for now.

However, we did discuss a plan to modify the requests to return some debug information. This way, we can use the information to further debug the issue. Currently, it’s a black box.

I don’t have better suggestions here, cc @kishanprmr

Hi Guys,
any updates ?
Thanks

1 Like

I’m having the same issue. I connected my personal and workspace accounts in two different connections, and they behave the same way. Clicking the Load Data button returns “Testing data failed. Please ensure that the settings are correct or try again.”

I’ve tried reconnecting both of them, forcing a contact update, and deleting and recreating the connections and it still behaves similarly.

I’m having the same issue as described above. My main account simply doesn’t work: No results found (“Testing data failed. Please ensure that the settings are correct or try again.”) However if I connect a different test account, it works fine.

I tried repeatedly disconnecting, reconnecting etc. without any change. I am looking forward to fixing this bug.

Hi @abuaboud
Any update ?