Facebook: "Connection failed, make sure client id and secret is correct. "

The Facebook integration connects fine, then goes to a “redirect url works!” plaintext message.

Doing the Connect button results in the error in the subject line. The key pair is copypasted from the source, so they cannot be incorrect.

The only theory is that AP is looking for different values than what the steps indicate and those steps are out-of-date. Either that or there’s a specific type of permission that they’re trying to invoke - but without more helpful information about what it wants, there’s no way to triage further.

App ID and App Secret are what we’re using. Doesn’t matter if it’s Development mode or Live mode.

Hello @CTRStage and welcome to our community :heart:
After the “redirect url works” does the window close and the button turns from “connect” to “disconnect”?

The redirect url window doesn’t close on its own, no. And the button doesn’t change.

Could you please disable any ad-guards or ad blockers you have while establishing the connection? sometimes these two disallow the connection from being established.

Nothing of the sort is enabled besides the standard browser treatments. Tried multiple browsers with the same result.

And I would note: the Twitter/X connection worked perfectly fine. So it’s doubtful it’s the browser; there’s something this connection is expecting that it’s not getting, and if I can know what that is, I can triage further. Facebook’s stuff is set up and the key pair is valid - if AP is having a different issue, a more specific error would help.

If you are on cloud, would you mind messaging me your email ? just so we can further investigate the issue.

Cloud, yes. And done.

8 days with no email or reply is disheartening.

Apparently the problem is that ActivePieces is asking for more permissions than are needed based on changes Facebook made. But I have no idea what permissions are desired because the instructions don’t even match the current Facebook Developers UI.

image

The application is granted standard rights on everything and advanced on the public_profile and email. So my theory is that there’s something else where your code is wanting advanced permissions for whatever reason (presumably due to whatever Facebook 2.0 changed, don’t know). But your instructions don’t specify what that is - or why.

So I can’t fix this until someone at ActivePieces can give more specifics as to the EXACT settings you want. Second to that, the instructions on the popup page need to be revisited as they’re out-of-date.

1 Like

I want to up and follow this because I have exactly the same issue with Instagram.
image

1 Like

image
Both are correct obviously.

1 Like

Is this ever going to be addressed?

We can’t be the only ones who are sending stuff to Facebook.

So I got no assist from ActivePieces. But I managed to get it working. Hopefully this can help point you in the right direction @Antoine_Piron (I assume that Instascam may need the same but not sure).

The instructions are wrong.

Don’t chose Facebook Login (that’s what the instructions say).

Choose Facebook Login for Business.

Also (and I don’t specifically know if it made a difference), I enabled the Javascript SDK as it’s disabled by default.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.