Error when Create Folder in Shared Google Drive

I’m trying to create the following flow:

Trigger: New Database Item added in Notion
Action: Create New Folder in Google Drive, name the folder from the new notion database item

I’m trying to use a Shared Google Drive for this but get the following error:

Error output is:

  "response": {
    "status": 404,
    "body": {
      "error": {
        "code": 404,
        "message": "File not found: 1IWh3Et1ciqRdajwjisDQXPHQC-xqQZwZ.",
        "errors": [
            "message": "File not found: 1IWh3Et1ciqRdajwjisDQXPHQC-xqQZwZ.",
            "domain": "global",
            "reason": "notFound",
            "location": "fileId",
            "locationType": "parameter"
  "request": {
    "body": {
      "mimeType": "application/",
      "name": "APFileUploadTest",
      "parents": [

This works when the folder is being created in My Drive but not in a Shared Drive.

I saw this fix was merged along with several related others over the past week, but am still getting the same issue I was before.

I’ve tried reconnecting drive, setting the folder share options to open, creating new flows, editing existing ones - still no success.

Any insights on this would be appreciated!

I just noticed it seems to be adding a period (.) to the folder ID which may be cause of the error? Not sure if that’s just the format of the error output or an issue with it’s use of the file id…

Did u solve this? If not, let me know as I think it can be another thing

Hi, thanks for the message - no, not solved, I was just speculating based off the error message.

What do you think may be causing?

can you share the full error you are getting from google drive?

The full error from the ActivePieces flow is pasted in the first message - is that the what you’re referring to?

Yeah, it’s a thing with the “parent folder”, maybe you don’t have permission to create other folders inside of that one? i don’t know…

Note the Id:

PS: The dot at the end is a API thing, should not be a problem.

You can try creating the folder inside another folder created by you, or without any parent folder at all.

Strange. I’m Manager of the parent folder and created it myself…

Have you used the upload to drive on a shared drive yourself successfully before?

I tried now, it worked just fine… I shared a folder from an account to the other one, and then created the folder through activepieces.

1 Like

Hey @CIVI what I see now is that your output is a json. That changed a few versions ago. So I recommend you to update your Activepieces and (if applicable) the Google drive piece. The last version of the piece is on one of my screenshots

JSON is back actually! @PFernandez98

daaaamn, then i’m the outdated one lol

Lol just a little bit this time :zipper_mouth_face:

So I can’t seem to see how to update the cloud version - I’ve tried creating a new flow, new connections, etc… and given the later conversation I’m not certain if that’s the issue.

I’m still stuck on this one, and curious how/why it’s functioning for you …


@kishanprmr Can you please take look there and add it to our polishing plan.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.