Cant seem to get my Trigger to work

Hello sorry for the newbie question but ive used a template ‘chatgpt-to-write-long-blog-posts-on-wordpress’

(Use ChatGPT to automate writing long blog posts on WordPress (1,500+ words) - Activepieces)

However i cant seem to get it triggered… its scheduled to run every minute apparently, and it has run once, but i cant get it to run again, ive added new rows, ive deleted rows… ive tried changeing the trigger to a scheduled run but tjhat didnt work then i saw someone mentioned a cron job but i cant find that trigger?

im a bit lost can any one point me in the right direction please?

Ive made all the connections

Please advise?

Many thanks


Hi @Mediamatic, did you publish the flow? (upper right corner)

Yes i did… thanks for the response

I am having the same issue. I’ve been working on it for 2-3 days with no luck. This flow will be fantastic when it is fully working.

Not sure if this will help in the meantime, but I have been able to get it to work in a semi-automatic format by going through the following steps once the flow has been built:

  1. Add one row at a time to the linked spreadsheet (I have the bulk data in a separate tab)
  2. In Activepieces, edit the process
  3. click on the New Row step and press ‘load data’ in the right-hand panel
  4. Press ‘test flow’ above flow diagram
  5. Repeat the process. I overwrite the row in active spreadsheet whilst the test run is working to save time.

Not ideal, but allows me to create a new article every couple of minutes.

I also have an issue where the main title is being added into the post as a H1, not in the title field. Is that down to the template or me missing a step?

Thank you Elwyn, thats what ie been doing but does the app autodetect a new row change or do i have to press test each time as that kind of defeats the automation idea if i have to do it manually ?

Many thanks again


Currently, I need to press both ‘load data’ (this resents to the new spreadsheet row) and then ‘test flow’ once I have changed the row on the spreadsheet. A little frustrating, as I am guessing it is likely a simple oversight that I am missing, but it is getting the job done for now.



1 Like

Is this the solution to this problem? It seems that a simple trigger should run without any issues whatsoever. Can someone please help? When the flow is tested it runs with no issues and you get all green checkmarks but thereafter it stops working completely. Please help.

After some testing and heartache, I think that I found the solution to this problem. Please check your OpenAI account for tokens to make sure that you have appropriate funds… I was getting an Error Code 429 - Rate limit reached for requests. Hope this helps.

Im afraid thats not the case with my account, ive always made sure i have enough credit

Howeverr the gentleman also on this thread is correct … i have to reload the spreadheet and reselect the row everytime i do a test run as the run doesnt seem to trigger

Hi, I am Facing the same issue. workflow doesn’t self trigger. please let me know if you find anything.

Hi @Nuwan_Fonseka

Which trigger did you select? Is your flow published?

I followed the example and used google sheets to trigger when a new field is entered. And yes i published , thank you

I have the same problem, Google sheet New row trigger does not trigger. When I published it, it worked that day and after that, it did not do anything. I had several new rows and flow did not started.

I was advised by Mo [ Support ] that if i removed the trigger ( Google sheets ) and replaced it with another trigger … then switched back to Google sheets it would update the Google sheets trigger to the latest code … which seemed to work.

Ill keep monitoring it but for now it seems to be working well.

Hi @Petar_Kordic,

I also wanted to ask if you deleted any rows after you pressed publish. The way the Google Sheets trigger currently works is that it stores the row count on publish and then keeps checking whether the row count increased or not.

In case you published the flow and then rows get deleted and new rows added again, it won’t detect until it exceeds the original row count.

Thank you,

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.