Can't login to Appsumo Tier 3 account

I’ve sent this request to the support email, DM in Discord to Mo and DM here to Mo, but not had a reply. I wanted to login yesterday to create a test flow and I haven’t been able to (the purple submit button changes to a logo and stays like that without going into admin).

I purchased Activepieces Tier 3 and it wouldn’t login, I tried resetting the password but it didn’t send a reset email.

I’ve then tried my other email address and that sent a password reset email and when I reset it, that didn’t login either.

Can someome plese help set-up the Tier 3 account?

And, where’s the best place to send support requests where personal information such as emails such have to be sent (I haven’t here posted the 2 emails I’ve tried)?

Thank you,

Hi Bharat, I replied on the support email :smiley: and discord DM.

Thank you!

i have the same problem i had rebought the tier 3 and its not reflecting in the account

Yes, solved. Thank you for fixing the issue Mo.

Please send an email to so I can cc appsumo as well

I could fix it without getting back to appsumo :smiley: Sorry for that

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.