Cannot connect active pieces to new Wordpress site

I added the plugin but for some reason it is saying my credentials are wrong. I tried connecting manually and managed to login.

Make sure you’re using the base URL of the website, not /wp-admin or /wp-login.php

Also, make sure your website is not password protected (the native password prompt that comes when you open the website).

If you’re sure about these points, can you tell me more about this? Does the error show in the connection popup or when you test the step?

it’s a .pro website. Maybe that’s the issue? Everything seems ok but it won’t manage to connect.
I cannot connect it in the popup for the Wordpress step.

I can’t see how being on a .pro domain could affect the connection. Can you send me a message here with a screenshot of your connection popup? Make sure I can’t see the password.

@abuaboud I’ve tested on this website with credentials that actually work on /wp-admin but doesn’t work on Activepieces. All the requests I tried with Postman with ?json=1 return HTML rather than JSON. I marked this thread as a bug but I can’t know where it comes from. It’s more of a WordPress issue.

I disabled/enabled all the plugins one by one while trying to see if they affect the response but I wasn’t able to identify the source of the problem. I’ll appreciate it if you take a look and see if you have a solution for it. Otherwise, we’ll have to close this as it’s not an Activepieces bug but more of a WordPress issue.

First of all I appreciate your help. Can you try to summarize the issue exactly so I can try to contact Wordpress regarding it? Thanks!

The issue is more with the Basic Auth plugin not WordPress in general since the plugin is not being effective on your WordPress instance

Very strange. Who can I contact? I think it works on another website I have as well. But only this .pro website doesn’t work. Are you sure there is no connection?

It doesn’t naturally ring a bell to me but it could be the reason if there is something that conflicts with it. @abuaboud should be able to dig more into it!

Hi @Meek_Mill

The REST API is not enabled on your website, due to Settings → Permalink is set to Plain (Changing this to post) fixes the issue.

I have updated the trouble shoot sections on Connection as well.

Thank you,

I just saw that you changed it. So it should work now? Hopefully I will get the chance to test it later today. If not then on Sunday.

Thanks! I appreciate the help!!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.