[BUG] Google Drive Upload File (MP4)

Hey everyone, I tried to upload a file to Google Drive and it successfully uploads, BUT it’s just a shell of the video…empty…despite a success message.


The uploaded video is 0 bytes, I even tried changing the extension to .mp4 and it didn’t help.

Hope this is something that can be fixed. MP4 files don’t seem to be handled well at all in Activepieces.

@kishanprmr Any thoughts on this?

So it seems that the problem exists when the Content-Disposition is set to attachment for mp4 files.

As such, instead of streaming the video in the browser, it downloads it. Not sure how that extends to the API action, but the result is 0KB mp4 files, even though the action is running successfully.

If anyone knows a way to make videos that download when visiting the URL work for the Upload file in the [Google Drive] piece, let me know! Thank you in advance :slight_smile:

Hi @S_M ,

How are you mapping File data for this action? Is it binary data or URL?

URL, but see my previous comment

@kishanprmr added there Sprint (15th April - 22nd April) · GitHub

1 Like

Thank you! Please make sure to note that the issue occurs when the Content-Disposition of a URL (containing the mp4 file) is set to attachment. As such, when you visit the URL, the mp4 file automatically downloads, instead of streaming. If it streams, mp4 file uploads action work fine. But when it downloads, the file is uploaded as empty (0KB). This is an important nuance @abuaboud @kishanprmr

I’m hoping these “attachment” mp4 files are supported by the upload action.

It started working randomly, same URL as originally tested, not sure what change was made, but we are good to go! :muscle:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.