Approval Link cannot be accessed

Hello everyone, I am new to activepieces and i am currently testing out how the workflow works. I run the activepieces using docker and I do not want any solution that involves the cloud because I just want to test how the activepieces works on local.

This is a brief overview of my workflow, the trigger is the submission of my form.

So upon submission, my discord has received the message as stated out in the workflow. But the problem is, the approval and rejection link cannot be accessed.

Can anyone help me with that? :frowning:

Thank you in advance!

Hi @snoopybubu

The cloud and community uses the same image, so it’s probably a mistake in configuration, are you sure the AP_FRONTEND_URL is set correctly in the variables? (Are sure for example it’s http)?

What issue do you get when you access the page?

Hi @abuaboud

I have tried running ngrok and changed the AP_FRONTEND_URL earlier this morning but it seems like ngrok is giving me another error. So i gave up on ngrok and used back http://localhost:8080 as my AP_FRONTEND_URL again just for the sake of testing.

As mentioned before, when I try to access the approval URL, its giving me this error:

But when i change the URL manually to http://localhost:8080/api/v1/flow-runs/test-run/requests/…?action=approve, it works. :pleading_face:

Why is that so?

Hi again,

I have switched my AP_FRONTEND_URL to ngrok and it gives rise to this error:

What should I do now? :pleading_face: