Ai returns spaces

I have been trying to get ai to return a simple response, i.e. “Al Jazeera”, which would allow a subsequent search of a google sheets, to allow a data return that would allow me to add future analysis to the ai via data inserted into the sheets.

However, every ai returns some of the same way, which leads me to believe it is a AP issue.

It always returns,

Al Jazeera"


" Al Jazeera"

This does not allow the subsequent search to function in sheets, as the spaces are disrupting the engine as the “first letter” is blank air space.

I have tried to code around this, but the const code always messes up code made by any ai, as it tells me the const code is not necessary. I’d rather have a return with ai, that functions, rather than ask for a coding solution, but I am stuck.

I suggested that it’s an Activepieces issue too when I tried OpenRouter too, but the team confirmed it’s the result we’re getting in the API response from OpenRouter.

I think we need to debug this further as it really bugs me too. The output should be clean.

Thanks for reporting this @thisthatjosh

This is solved while ago, marking as solved.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.