Put Value to Storage Error

I’m trying to put the following info in a key using PUT Storage:


"properties": {

    "Multi-select Produto": {

      "multi_select": [


          "name": "TESTE A",

          "color": "default"






But something weird is happening, here’s the result:

The problem that is causing this is the last “}”. If i remove the last one, it works:

But i need the last “}”. How can i fix this?

Hi there @jrolivieri, hope all is well :star2:

In case you don’t know the step’s output has been switched to YAML

If you put something that’s a JSON it will be shown in YAML format, there is nothing wrong with your flow.

Please bare in mind that the result of a storage step is string, so you will need to use a JSON step to convert it back to JSON.

But i need the result to be in JSON… If i put the YAML result in a HTTP Request body (JSON) i get an error.

Is there a way to convert this YAML result back to JSON?

Hi @jrolivieri

You can use it directly in http request, It should be JSON same as you stored it.

@Abdul @abuaboud

I tried to use the result of PUT Storage in the JSON Body (HTTP Request), but i got this error:

But if i use the original code in the JSON Body (HTTP Request), it works fine:

Sorry for my ignorance, but what am i doing wrong?

I tried to use a JSON step to convert the Put Storage result back to JSON, but i keep getting a YAML result:

What am i doing wrong here?

I figured it out! I just had to use dynamic value:


Hi Abdul,

Unfortunalty the Text to JSON does not work for me:

Manually copied the HTML


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.