My Workflow Was Completed Deleted by the System and I Can View Old Versions But Not Do Anything Else

I spent hours on this and when working on, it just decided to delete my current version in it’s entirety and now will not allow me to reinstall drafts, but view them

Hi @Dan_Mullaney2

Sorry for that can you send me your account email to support@activepieces.com

I will fix the restoration and check why it’s happens

Would love to hear what the resolution was for this… as this also happened to me after spending 8 hours working on a flow, and then it’s just gone… and no chance to restore from versions to draft.

It’s flakey af, and makes this software almost unusable, or at the very least, a stress to work with knowing you could lose all you work at any second for no reason.

Hi @planetx

I understand your frustration but just to confirm there is no data lost, it just created new draft version and failed to copy it to the new version

As i said please send to the email above, we will restore it until we find the root issue, it seems effecting certain triggers

Hi @Dan_Mullaney2 could you please message me your email so we can restore your flow ?

Hi there @planetx your flow should be restored now, please check your dashboard and let us know if all is restored to the state it was before.

@Abdul @abuaboud
I have the same thing happened to me last night and couldn’t restore on any of my previous 9 drafts. This happened on my self hosted account though.

If you hover over the exclamation mark, it says, “Please contact support as your published flow has a problem”
image

The current draft is empty. I can “view” the previous versions but will not restore.

When I view a previous version, I can see the entire flow.

The weird thing is, the published flow executes, but I can’t edit since the draft is completely blank.

I have the same problem with self-hosted version. Got a “connection lost” warning, refreshed and flow was gone entirely, and I can’t edit published version of the flow. Published version works but it’s in read-only mode.

“Use as draft” option doesn’t work.

1

Hi @Eugene and @menacestudio

I think the data for 0.4.7 in store piece were messed up, @Abdul have fixed it, can you try restore the flow from draft and let me know if you still any issues.

@abuaboud I updated the self hosted version to the latest version in docker compose according to the documentation but it’s still not restoring for me.

Hi @menacestudio Do you have store piece in it? do you mind export the flow in published mode and send it to me?

Edit: contacted @menacestudio and It’s working now, the metadata data is now updated (https://cloud.activepieces.com/api/v1/pieces/@activepieces/piece-store?version=0.4.7)

You can now revert to old draft

2 Likes

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.