Issues with Wordpress connection

Connection failed: REST API is not reachable, visit www.amethystinsight.com/wp-admin/wp-json" make sure your settings (Settings → Permalinks) are set to “Post name” (or any option other than “Plain”) and disable any security plugins that might block the REST API

I have made sure my settings are correct and I have tried with and without wp-admin

@Robin_Deans can you share the result of you Tools->Site Health to confirm the REST endpoint is active?

It says REST API is available

Hi Robin,

Trying to trouble shoot, do you have some screenshots of the error?

And a question for now:

Did you use the following?

Username: the wordpress username or e-mailadres?
Password: (not recommended) user password or (recommended) application password
Website: https://amethystinsight.com/

The website should only be the domain, like above.

Kr Bram

I’m not sure of the difference between the user password and the application password.


Changed the web address and now I’m getting invalid credentials.

That is good! So we have been able to fix the first issue!:relieved:

On to the next one, the error message says that the password for your account is incorrect.

I think you have used the password you usually login to in Wordpress. That is possible but not very save, as if this password would provide access to all your functions within wordpress.

Instead you can use the application password.

In WP go to - users - you own user - then scroll down and you see “application password”. Create a new password for Active pieces and use that one. This password only allows to set actions via API so it does not have the same possibilities you have when you login as a user. With the possibilities of the application password you have all you need.

Hope this works!

Kr Bram

1 Like

This isn’t an option for me.

I got it - I had to turn on 2FA!

Perfect! Does the connection work now?

Solving these things is always a bit of a puzzle

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.