Google Drive - Read File - Failed to store entry [object ReadableStream]

Use case: I am trying to convert a json file of a transcript to a readable doc file.

The trigger is a new Drive file added to the folder. That works.
The next step, I believe, should be reading the file from the Drive folder, so I set the read file to be the New File ID.

Upon testing I get the error: Failed to store entry [object ReadableStream]

Not sure what I am doing wrong here.

1 Like

I had the same problem when reading an mp3 or mp4 file (no matter the size). I will follow this thread to hope for a solution.

I am also trying to use a WAV file in a different piece… This is not very intuitive, yet I do not see anyone having issues, so I assume I am missing something.

Basically I have ASR transcribing audio files and I want to compare the results and let the business owner do the same easily, kind of automate it.

So translate the transcription to a doc, and for the audio transcribe it using Whisper.

On another whisper thread it says to send it to S3 for the file name, since it apparently doesnt get a direct link from Drive… OK, seems unecessary, but I set it up anyway, and BAM same type of error.

  "file": [
    "Expected file url or base64 with mimeType, but found value:"

I really wish there was some kind of tutorial with this. Waiting for responses is painful.

I attempted to try to bypass Google Drive, and just use S3 as the trigger and the read file… Still doesnt work. Same error… I am at a loss, I must be doing something wrong, it just isnt obvious what it is.

I saw this video that a user shared on the Activepieces Discord and for him, it worked perfectly: but not sure why is not working for us. And it’s not a shared Google Drive or anything.

I watched the same one. Maybe it is a bug…? Because it definitely does not work like that for me.

Just curious, you using the open source version, or cloud based? I am on the cloud based version, and thinking about installing the open source on the computer to see if that works…


I am taking look right now

Thank you!! Looking forward for a solution.

There was an issue with dealing files in test mode, now it should be fixed.

Unfortunately, I just tested and I still got the same Failed Test message.

I am trying to reproduce the issue, just to confirm is this google drive on cloud environment?

Yes, from active pieces cloud and Google drive cloud.

Hi @ddesign and @Michael_ES can you please try again If it’s not fixed, can you please book me for 15 minutes call I would love to check it out with you to find the root cause.

This should be fixed, if you still experience the issue please upgrade to latest version of activepieces in case you are self hosting.