Flow stuck in "Running" - No way to stop

Is there a way to stop a run? I found an error so my flow runs that I am testing (via live data) aren’t completing. They’re just stuck in “running.” Is there a way to stop them? If so, I could use a pointer. If not, I’d love to suggest this as a feature!

1 Like

So it turns out the error isn’t where I thought. It looks like my custom code step is just spinning. (At least in test.) Which is weird, because it only converts a number from one format to another and was working fine. But doesn’t seem to be now. The runs have been running over an hour. I have turned off that flow, duplicated it, and was re-building it. (Which is how I found out the code step wasn’t working.)

Even with the duplicated flow shut off, I can’t see the code that was in the box.

Shared with Zight

which was something along these lines:
const e164PhoneNumber = +1${numericPhoneNumber};
return e164PhoneNumber;
where the first number is a number taken from an earlier step.

So not sure what’s gone wrong. But any help would be appreciated!

I got the code step re-created and working. But still having issues. (And those previous flows are still running.) I checked my connections tab and saw a Google connection error:

Got that resolved, but now I have the old flows stuck on running as well as the new ones. :confused:

Shared with Zight

The one flow in the middle that failed is triggered from a webhook - not a Google sheet.

The reason I updated the title is that I found a way to remove the previous attempts from running status. I deleted the flows. (This is obviously not a great solution and I think a “stop flow” button would be a nice feature!)

But, I am still having issues. Before deleting the 2 flows, I duplicated one of them. I deleted the code step from the new flow. I then went through it step by step with sample data, testing every piece.

The flow works like this: data gets entered into Jotform. Since the jotform piece isn’t working correctly, I have Jotform push the data to a Google sheet. That new row triggers the flow. (Which is working.) It then reads the data from the spreadsheet row. Re-formats the phone number from xxx-xxx-xxxx to e164 format. It then passes the data via an http post to an api. If the http request does not return a 200, then it waits for 5 minutes and tries again. If there’s still no 200, then it considers it as a failure and updates the Google sheet.

If either of those HTTP requests does return a 200, then it considers it a success and updates the Google sheet.

I tested the whole thing all the way through, piece by piece. Worked fine.

But, when I pushed it live and filled out my form, the flow is once again stuck in running status. I am not pushing additional rows this time. (And I turned down the “poll rows” to 1.) I’m going to quit on this for the night and see if a) the flow ever finishes. (It isn’t that complicated.) and b) what advice you have to offer! :slight_smile:


Hi @trellyn Please book me for a call Let's talk! | Mohammad Abu Aboud | Cal.com
I am tracking couple of issues down right now

This seems very similar to the issue I am getting: AP Docker Container Crashing on code step

1 Like

I booked a meeting for tomorrow morning (for my time zone at least). But, I wanted to let you know that it was 100% the code step. I changed up my triggering form to do the data manipulation before sending the data to my Google sheet. Removed the code step from my flow and it’s working fine. I do still have one old flow that is still stuck in running, but for now, the workaround is working for me.

If you still want to meet, it’s on my calendar! If you want to cancel to use that time elsewhere, that’s fine, too. :slight_smile:


This is due to code step bug as we discussed earlier, Now the fix is released.

We are fixing the stuck flows case by case there are small number of flows, I will get back to you here and other threads in the community tonight.

Thank you for your understanding

hi @abuaboud - wanted to share that my runs have also been stuck - more details are here:

let me know if there are ways to unstick them or if I need to recreate something to fix it. thanks

Nevermind, I was able to see them run by copying the flow and retriggering

Hi @Vertico_Labs are they still stuck?

nope we’re good now! thanks

For Redis we will support visual way to see queues in next version (0.12.0) this will help resolve most of the issues there.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.