Delay piece causing internal error

I have a longer workflow that should span over several days with various loops and delays. The flow runs until the first delay and then triggers an internal error. I am unable to access the run under “runs”; it does not open, so my suspicion is that the issue lies with the delay function.

Continuing the discussion from Multiple Delays in a Workflow do not work?:


Hi @Gio,

I think it might be a log size issue. Could you please let me know if the flow executes successfully? For example, do you see the results in your apps?

Moving this to bugs.

Thank you for your reply. Yes the flow is running until the first “delay” piece.

Is the log-file something I need to care on my side?

good day @abuaboud
may I come back to this topic? could you check already? On my side, the pieces are still causing internal errors.

and one run is hanging since 4 days


Hi @Gio

I will publish fix for the log issue today, and let’s check if it fixes this issue.

will keep you updated.

I think it’s fixed now, please try again and let me know if it appears

Thank you for addressing the problem. I’m not sure if it’s working correctly. This morning there was another internal error, and now when I restarted the task, it executed three times! (I’m not entirely sure, but I suspect the webhook was triggered multiple times by my system). I’ll let you know tomorrow if the task changes from paused to internal error, or if the tasks are now being executed correctly.

Ouch this is quite strange, Does it happen with any other flow? Is there a way for me to reproduce the error like simple flow.

Hi @abuaboud
I tried on several scenarios, and the delay option always causes the same internal error. I tried a scenario with 10 minutes, 1 hour and several hours.
So there is definitively a bug.
The version I have is V0.3.6
Thanks in advance for your help!

Good day @abuaboud

I tested it again. It seems that the “delay” function works in principle. However, in my case, there are 3 delays built into a loop. Could that be the reason?

P.S.: Because I can’t open the log in “run” in case of an internal error, I can’t see exactly where it’s getting stuck.

Hi @here

I think this related, and now it should be fixed.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.